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IMPROVED AND NEW FUNCTIONS IN CNCNET DNC 11.02

GENERAL IMPROVEMENTS

CNCnet DNC 11.02 was developed in a 64Bit environment and is suitable for all x86 (32 Bit) and x64 (64 Bit)
versions of Windows XP, Windows Vista, Windows Server 2003, Windows Server 2008 und Windows 7.
CNCnet DNC 11.02 does not depend on external software components or .NET additions and does not
store any information in the registry of your computer. Per installed instance CNCnet DNC 11.02 can
operate up to 100 connected machines. Of course you can install and run multiple instances of the program.

IMPROVED AND NEW FUNCTIONS

FAILSAFE OPERATION MODE

You can operate CNCnet DNC 11.02 in a failsafe operation mode by copying the whole application directory
into a new folder and start the program a second time. In case of an error in the primary program you can
immediately continue working with the second program by switching on the specific port. This is also the
preferred method for integration and test of new machines as it allows the main program to continue to
work without the need for a restart.

INTEGRATES WITH YOUR FAVORITE NC-EDITOR

You can seamlessly integrate your favorite NC-Editor with CNCnet DNC 11.02 by setting this Editor in
CNCnet DNC as your preferred program for all NC File modifications. CNCnet DNC 11.02 then automatically
calls your NC Editor every time you perform a NC File modification. Here's an example of using the cost free
file editor notepad++ for comparing multiple NC-Files:

CNCnet DNC :: System Parameters il
—Logbook Entries ———— —Editar Path
I 1000 ill I Cu\Program Files (x36)\Mokepad++inotepad++.exe  Search... |

[8€]F-\NCPROG', GILDESEND", 13950.nc - Notepad++ o =] ]
Datei Bearbeiten Suchen Ansicht Format Sprachen Einstelungen Mskro  Ausfihren TextFX  Erweiterungen Fenster 7 %

| cHHE 5 8|4 OR(2e |t <[EE|=[1EFEI | OEPEHR=sv= >
4 E 129500 | [avEa El

—Received Files

[~ Backup Wersion [

[= 13351.HE |

1L ®%_N_13951 NPFuGRIN =
2 :$PATH=/_N_WKS_DIR/_N_1385I

3 N10 ;EBezeichnung:LFR. Druc!
i Nz0 :irbeicsgang: Innenausd:
5 N30 ;WUerkzeuge: BRI
&
-
=]

1 3 N 13951 HPFORIME =
2 ;$PATH=/_N_WKS_DIR/_N_139!
i Ni0 ;EBezeichnung:LFR. Drw
4 NzD :Arbeitagang: Inhenausi
5 N30 ; Werkzeuge : BRI
&
i
=]

| JBAK

M40 ;WzMr.T_3_ASchr.0.s
M50 ;WeNr.T_12 TISchr.0.8
NSO :WzNe. 222777

W40 ;WzNr.T_3_ASchr.0.8
ME0 ;WezNr.T_12 ISchr.0.8
WeO Wz, 272727

L

=) Ne0 ;WzNr.T _3_ASchl.O0.4 =] Neo ;WzNr.T _3_ASchl.O.4
10 W70 ;WeNr.T_12_TISchl.0.4 10 N70 ;WeNr.T_12_ISchl.0.4
11 NS0 ;3pannbacken:Hart -16. 11 N90 ;Spannbacken:Hart -16
1, N100 :Zpannart: Von Lussen 1z N100 :Zpannarc: WVon Lusse)
13 MN110 ;Spanndruck: 15 bar @R 13 N110 ;Spanndruck:15 bhar@@
14 N1z0 ;Bandzeit: BN = 14 HN1Z0 ;Bandzeit: I
15 W130 ;Bemerkung:T12 ISchl 1 15 N130 :EBemerkung: _Ischl
16 N140 ; henderung: 16 N140 ; kenderung: @2DE
17 N150 ;Programm erstellt =am 17 N1i50 ;Programm erstellt =z
15 N160 lims=1. L 18 N160 lims=12006E00

19 N170 stoprel
z0 N1s0 G50 G54l
21 N250 T3 D1 ;##HEHEHEHEER:T

19 N170 stopreEIMI
20 N180 G20 GS4ERN
ol M250 T3 D1 :#E#E#SEEGHEE

2z MNZg0 G996 3230 MO4 M103 MR 22 Nzg0 G96 3230 MO4 Mi0SEERE
23 Nz70 GO 87 ZSO6RR 23 N270 GO X857 ZSOGR
24 Nz80 GO - ZZ (RN 24 Hz80 GO - 2z EERNd
= MPA0. 201 7_15 R0 2 e _I_I = wran N1 7o1E TA omm_lLI
Ll » q »
|NnrmaltextF\Ie ‘nhchar:lls? nbling : 45 |Ln:1 Col:2 Sel:0 |Dns\Windﬂws ANST ms
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MORE INFORMATION IN THE MAIN MENU

The information field on the bottom of the main menu shows the protocol, the transmission speed, data
bits, parity, stop bits and the COM port number of the currently selected port. The picture left of the
machine name shows the selected protocol or the selected handshake of the port (black = hardware, red =
software). If you move the mouse pointer over the button you can see further important settings of the
selected machine.

£* CNCnet : DNC 11.02 2 =1 ]

File Command Configuration Lewels Tools Help

. inventcom

?|ss P Al Pi|B

Skatus

1@ = Hiles W 30 Iwaiting

2 232 HEAHandshake (O=MOME 1=3W Z=HW):
Tt 2 Timeout: 30 sec,
3 232 Hiles| ¥ 2 Timeouk: 15 sec,
——Auto Receive: 1 (0=0FF 1=0M) Sync: " M
4 222 MERRemote Contral: 1 (0=0FF 1=0M) File: '9999, nc'
|F'Dr|:: 1 [Miles M 30] RS5-232: 4800 5 N 1 COM42 14:47:56

FIND ERRORS QUICKLY

During transmission of an NC-File CNCnet DNC 11.02 immediately shows you where you have to look for a
potential error. The CTS Message at Port 1 indicates that the cable between the machine and the serial
interface is disconnected or broken whereas the “disconnected” message at Port 2 indicates a problem
with the serial interface (cannot be opened).

f* CNCnet = DNC 11.02 = =lo x|

File Command Configuration Lewels Tools Help

?lssPn|fOlepil|B

; ol | arie . _ w 0 Privileged |
Deg| Een| oxg

Skart Tirme
1 @ =t  Hiles N30 — F1iMCPROGYGILDESEMD' 1 3950, MC 14:51:02  [ME
5 z3t NEF G000 I disconnected
3 232 Miles N 40 I waiting
4 23z HEF 400 I waiting
| Part: 1 [Miles M 30] RS-232: 4800 8 N 1 COM42 14:51:25
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MULTI-LEVEL AUTO RECEPTION MODE
CNCnet DNC 11.02 allows you to build NC-File names from up to 5 different synchronization strings in

incoming content. For example: You'd like to store your NC Files by the material number instead of the NC-

)

-t

File number. Unfortunately the operators do not always enter the material number or enter the
synchronization string in variants. The machine operators write MaNr, Matr, Mat or nothing.

[P 13950.nc - Notepad

Fil=  Edit

Format Miew Help

inventcom

=10l

H_M_13951_MPF

M1O ;Mat:1-015ECQS0BRL

M20 ;Matr:1l-0LlSEQSOERL
P30 sManr :1-015E0S0BRL
M3 wWENr.T_3_aschr.0.8

PR

MED WZMNr.
MED wWzeNr.T_3_aschl. 0.4
MO wWzNr.T_12_Ischl. 0.4

M110 3 Spanndruck:15 bar
W1z20 ;Bandzeit:
MN140 ;Aenderung:

M160 Tims=1200

ki

MS0 ;wzNr.T_12_Ischr.(.8

s $PATH=/_N_WKS_DIR/_N_13950_WPD

P1.1
P1.3
P1.
P1.5
P1.7

NSO ;spannbacken:Hart -16.% mm
MlOO ;Spannart: won Aussen nach Innen

Kor.l wp .
Kor.l Wi,
Kar. wpl.
Kor.l wpl.
Kor.l wpl.

MLl30 ;Bemerkung:T1l2_Isch]l mit Schrupphlatt 0.8

M1S0 ;Programm erstellt am 08.02.07 von Unrecht Christian

A

In the Auto Reception dialog you can now enter up to 5 variants (Sets) for creation of the name. You set the
synchronization expression for Set 1 to Mat:, the one for Set 2 to MaNr. a.s.o. In Set 5 you enter %_N_ to

allow storage of NC-Files that do not contain a material number.

CNCnet DNC :: Auto Reception Configuration of P

— Cptions

v on

[~ Reception discontinues active sending

Min. Characters | 30

Timeout (Sec,) |2

—Parameter Set

SET 2
SET 3
SET 4 Max
SETS

—Walid Characters

v mMumbers
v 2lpha

Iralid

10

.

11

—Create File Mame Fram;

Sync, Expression I Mat:|

Add befare Mame

Add after Mame

+ Character Fill ko Length I 0 j W, I
End Extension I C j
| ik I Cancel | Help |
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IMPROVED TIMEOUT HANDLING

Timeout handling was readjusted. If you set Timeout Send(TX) After Start to 0 the program waits 200
seconds for a reply from the machine, after 200 seconds it terminates the transmission. You only have to
enter a value here if you like to wait more or less than 200 seconds.

OVERLAPPING SEND/RECEIVE

You can now instruct CNCnet DNC 11.02 to receive or send a NC-File while another operation is active. As
soon as the first operation is finished, the second starts.

EXTENDED CHARACTER HANDLING

CNCnet DNC 11.02 allows you to send from a defined character or from a defined string. This is useful if, for
example, your CAM system adds long comments to the NC File that are not needed by the controller. (e.g.
Trumpf CAM System). You can also send your NC-File from a defined line number. It is now possible to
exchange a defined character by a number of another defined character. You can receive an NC-File till a
defined string comes in or store the NC-File content after reception of a defined character.

CNCnet DNC :: Character Handling of Port 21 { Niles N3 |
—3end —Receive
Replace Send from Replace
000 00 MUL  -= 000 00 MUL  « | ------------- j 000 00 MUL  -= 000 00 MUL ﬂ
ool 01l 50H -= 001 01 SoH ool 01 5oH -= 001 01 SOH
002 02 ST -= 002 02 5TX Character 002 02 5T« -= 002 02 5Tx
003 03 ETX -= 003 03 ET= I 003 03 ET< -= 003 03 ETx
004 04 EOT -= 004 04 EOT 004 04 EQT  -= 004 04 EOT
005 05 ENG  -> 005 05 ENG Line 005 05 EMNG  -= 005 05 ENG
006 06 ACK  -= 006 06 ACK 0 006 06 &CK  -= 006 06 ACK
N7 07 RFI -~ NnN7 N7 _FFI LI I N7 A7 RFL -= N7 N7 FFI ﬂ
Delete Delete Receive il
" Replace I 000 00 MUL vI 1.|
' 2 |
before '
Store From
% Insert | 0d 00 ML vI
M. IIj j [ Excl. Char
Leading Seq. dd Add Trailing Sedq. ™ Replace EOL
by
| 000 00 HUL = | | <o Daka == | | 000 0O NUL * | ICR |

Mr. I a ill g IIZI_j [ Binary
Reset k. Zancel Help
_ et | | |
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FEEDBACK MESSAGES FOR EVERY MACHINE

CNCnet DNC 11.02 now has the ability to add a suitable feedback file for every connected control which
informs the machine operator about faulty input or available NC-Files. An example for a Sinumerik 840
controller Sin840.mt (Messages for example ,,NC File not found ") and Sin840.dt (Content of the machines
directory at the network computer formatted as NC file for the controller) is already included. For additional
feedback files you just have to copy and modify these examples in a way that allows the controller to
understand the content.

[ Sing40.mt - Notepad -0 |
File Edit Faormat Yiew Help

%_N_DOE_MPF =]
ML € $mMsG D

Mz M30

< M 4

VERSION CONTROL FOR RECEIVED NC-FILES

In addition to the function of making a backup copy of an existing file when a new file with the same name
is received CNCnet DNC 11.02 now has the ability to make a copy of every incoming version of the NC-File.
You can activate the function in Configuration->System->Settings->Received Files->Version. When an NC-
File is received a new copy of the existing NC-file with a numeric version extension is added to the
directory. For example from 13951-0.NC to 13951-2.NC:

& F:'NCPROG GILDEREC __ =10 x|
File Edit Wiew Favorites Tools  Help ;1.'
e Back. [ J lﬁ 7 Search i Folders = 2 n

Address [|-5) FH\NCPROGIGILDEREC =] Ese
Mame = | Size | Type | Drate Modified :l
QISQSI-D.NC ZKE MCFile 412002011 9:1¢
EISQSI-I.NC ZKBE MCFile 412112011 920
EISBSI-E.NC 1KE MNCFile 412112011 9:2¢
QISQSI.NC ZKB MCFile 5/10/2011 9:51
g 13952 M S2KE MCFile 5fafz011 1:06
EISQSS.NC ZKBE MCFile 2l24/2011 11:7
QISQSE-D.NC 1KE MCFile 4f14/2011 10:2
QIS‘BSE\.NC 1KE MNCFile Sl2/2011 10:4¢
Q 13957 .MC 1KE MNCFile ZIZziz011 143
@49551.&1(: ZKBE MCFile 3N0jz011 12

-

1| | 3

18 objects |62.3 KB | ¢ My Computer i
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REMOTE CONTROL OF CNCNET

If you activate the function Configuration->System->Settings->Allow External CNCnet DNC 11.02 now also
can be operated by an external MES or ERP program. The MES or ERP program can then write the defined
file (e.g. @_0030020_f.cmd) which causes CNCnet DNC 11.02 to perform the contained actions (e.g.
0001DS:SENDDATA:1234.TXTFILES = Send NC File 1234.txt to machine on Port1)

CNCnet DNC :: 5ystem Parameters il
—Logboak Entties —————  —Editar Path
I 1000 ill I CeiProgram Files (x36)\MNotepad++inotepad++.exe | Search. .. |
—Received Files ———— Batch File
[ Backup Wersion [ [ Modify Allow Exteral v
| BAK | F:ACNCRet DNCE\Cradbat@_0030020_F.cmd Search. .. |

e, I Cancel Help |

All possible commands can be edited and immediately tested by the function Command->Command
Queue->Edit batch file.

Edit Batch File @_0030020_ F E

—Description

External Batch file from HID_TM

— Commands
#ﬂ # 1 SEMDDATA: 1234, TATFILES
Z5TOP:
Delete | Wiy aik; | Send | Receive |

k. I Cancel | Execute | Help |
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MONITORING OF COM INTERFACE STATES

By using the COM Port Status which can be found in Tools->COM Port Status you can easily monitor all
states of the selected serial port for example are the handshake signals up or down or is any content in the
transmission or reception buffer. In the example shown the cable to the controller is not plugged in
(CTSHold).

CNCnet DNC :: Port#1: Com Skatus =l

[v CtsHold : Wwaiting For the TS (clear-to-send) signal

[ DsrHold : Waiting For the DSR. (data-set-ready) signal

[ RlsdHald @ Waiting For the RLSD (receive-line-signal-detect) signal
[ %offHold: Waiting because the BOFF characker was received

[ offSent : Waiting because the ¥OFF characker was transmitted
[ Eof : The end-of-file (EOF) character has been received

[ Twirn : Characker from TransmitCommChar queued For bransmission

Murnber of bytes received buk nok yet read: I 0
Mr. of bytes of user daka remaining ko be kransmitted: I o

PORT PARAMETER DOCUMENTATION

CNCnet DNC 11.02 now has a function that allows you to backup and display all settings and parameters for
a specific machine. You find the function under Configuration->Port->Options->List Port Parameters.

[P NilesN30.Ext - Motepad O] x|
File Edit Format Yiew Help
[FPort rummer #1 i’
ControlMame Miles MW 30
SectionMame
CLeueEnaked 1
GroupIdle 10
IMode 0
AutoreceiveEnakhled 1
AutoreceiveminChars 30
AUt OreceiveTimeout 2
IOFarameters

mask7hit 4]

Baudrate 4800

Catabits g

Stopbits 1

Parity M

-

KN H
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LOGGING OF RECEIVED NC-FILES

CNCnet DNC 11.02 now has a logging function that shows all received NC-Files. You find the function under
File->Received Files. The files can be selected per machine and be edited directly from the dialog window:

Received Files

001 Gilde MEF 600 & FMCPROGYGILDEREC, 13951, MC 2011.04.09 10 =
001 Gilde MEF 600 & FMCPROGYGILDEREC, 13951, MC 2011.04,09 12
001 Gilde MEF 600 & Fi\NCPROGYGILDERECH 13951 MC 2011.04,09 1:
001 iGEilde MEF 600 & FONCPROGYSILDEREC 13951 MC 2011.04.09 1:
Gilde MEF 600 & F: GILDERECI13951.MC  2011.04.09 1
001 Gilde MEF 600 & Fi\NCPROGYGILDERECH 13951 MC 2011.04,09 1:
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951, MC 2011.04.09 1:
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951, MC 2011.04.09 1:
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951, MC 2011.04.09 1:
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951, MC 2011.04.09 1:
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951, MC 2011.04.09  1f
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951, MC 2011.04.09 1f
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951, MC 2011.04.09  1f
001 Gilde MEF 600 & Fi\NCPROGYGILDEREC) 13951 . MC 2011.04,.09 IELI
—File
FANCPROGYGILDEREC)13951.MC 2011.05.10 13:39:38 1167 Bytes
Remove Line | Delete File | Edit File Standard g
Batch File (Ext.)

:(,‘1

-

—Select Port

MEF a0 l-_l

il 40
MEF 400

inventcom

ik I Cancel
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COMPARE NC-FILES

Under File->Compare Files you can find a handy function that allows quick comparison of two files if needed
also in hexadecimal form.

Files

Compare

—Seleck Files

=10l x|

Hex [

Left | F:\NCPROGIGILDESEND13950.ne 11:6:35 19.2.2011 1167 Bytes

| 1. % N_13951_MPF

Right | F:\NCPROGIGILDEREC,13951-0.MC %:14:51 20.4.2011 1167 Bytes

| 1. %%_M_13951_MPF

e Y
T T R e i

«‘f‘

—Compare Files = Identical

PATH=] N_WES_DIRS N_13950 %W
M10 ;BezeichnungiLFR. Druckscheibe 1
K20 ;Arbeitsgang:Innenausdrehen
M30 ;Werkzeuge:

M40 Wzl T_3_ASchr.0.8 Pl.1

NSO Wzl T_12_ISche.0.5 Pl.3

MED ;Wzhr, 777777 Pl

MED Wzl T_3_ASchl.0.4 PLS
. N70 3WNr. T_12_ISchl.0.4 Pl7

. M30 ;spannbacken:Hart -16.9 mm

. M100 ;Spannart: Yon Aussen nach Inr
. M110 ;Spanndruck: 15 bar

. M120 ;Bandzeit:

. M130 ;Bemerkung: T12_ISchl mit Schel
. M140 ;Aenderuno:

. M150 ;Programm erstelt am 08.02.07
M1 AN lirne=1 700 | _ILI
3

wion 45

. M90 ;Spannbacken:Hart -16.9 mm

. MW110 ;Spanndruck: 15 bar

. M120 ;Bandzeit:

. M130 Bemerkung: T12_ISchl mit Schro
. M140 ;Aenderung:

. N150 ;Programm erstellt am 08.02.07
. M160 lims=1200 I _ILI
3

EPATH=/ M_WES_DIR/ M_13950 W
M10 ;Bezeichnung:LFR. Druckscheibe 1
MZ0 ;Arbeitsgang:Innenausdrehen
N30 ;werkzeuge:

M40 ;wWzNr, T_3_ASchr.0.5 Al.1
NSO Wzhr.T_12_ISchr.0.8 Pl.3
MNED ;Wzhr, 777777 Fl.

MED ;WzNr,T_3_ASchl.0.4 Pl.S
M70 ;WzMr, T_12_ISchl.0.4 Pl.7

K100 ;Spannart: Yon Aussen nach Inr

vion 45

Close |
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EXTENSIVE DATABASE-INTEGRATION

CNCnet DNC 11.02 allows you direct integration of your controllers with your MES or ERP solution. CNCnet
DNC 11.02 provides connectivity from simple text based databases (Index Database) up to all databases that
can be accessed by an UDL (Universal Data Link) file like MS Access, SQL Server, Oracle, MySQL and
SAP’s MaxDB. CNCnet DNC 11.02 allows to store information about received NC-Files in your database as
well as retrieval of NC-Files from a database. Retrieval can be done by a set of configurable fields like
program name, material name or part name. The NC-Files themselves remain in the typical directory
structure.

CNCnet DNC :: Received Files - Configure |
—Database
UL File | DNC_UPLOAD. udl
DB Table | HCUP
CNCnet DNC :: Database =l
—Field Names —Database
Program MName I Proghame DL File I DM _ D OWHLOA D, udl
Reception Tvpe | Auto DB Table | NCFILES
Resource Mr, I MaterialMarme
—Field Mames
Machire Murmber I ChChr
Part Murnber I Partho
Description [ PartText
Part: Mame | Parthlame
— &ckivation Program Mame I ProgMame

v 1Incl, File Ext.?

—Program Directary

Cal

Directory I WMILLYMC 001",

Ok, I Cancel
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